RetroPieでnesのromが起動できない件

2015年1月2日

RaspberryPi Tips ゲーム

正月休みをほぼ「RetroPie」実装で費やしてしまったわけだが、いくつかのIssueも見つけられた。 まず、「RetroPie」にはver1.1とver2.3の2つのイメージが用意されていて、低いバージョンは初心者用、上のバージョンは上級者用という事らしい。 ただ、どちらのバージョンでもnesがすんなり起動できないことには変わりない。 そもそも、うちでどういう環境なのか記述する
# TOSHIBA42型液晶テレビ(HDMI接続) # RaspberryPi type-b # SD-Card 32GB # net:自宅LAN環境にEtherケーブルで接続 # 電源:iPhone用の電源充電用USBコネクタで接続

症状

nesのrom一覧を表示するところまでは問題なし、 romを選択して起動しようとすると、画面が何度か切り替わり、いくつかのエラーメッセージっぽいのが出て(素早く消えるので、読めない) rom一覧画面に戻ってきてしまう。

エラーメッセージ

macのターミナルからemulationStation起動してメッセージを取得してみた

1回目

# ============================================== # Press 'x' or 'm' to configure video output options for neslibretro # tvservice-client: Failed to connect to TV service: -1 # Frontend supports RGB565 - will use that instead of XRGB1555. # RetroArch [ERROR] :: load_content :: Failed to load game. # ==============================================

2回目

# ============================================== # performance # Powering on HDMI with explicit settings (CEA mode 4) # Frontend supports RGB565 - will use that instead of XRGB1555. # RetroArch [ERROR] :: load_content :: Failed to load game. # Powering on HDMI with preferred settings # ioctl FBIOPUT_VSCREENINFO: Success # ondemand # ============================================== このエラーを見た時にHDMIの解像度が高過ぎるのかと思って、別の小さいモニタで試みたが、結果は同じ。 おそらく問題は
RetroArch [ERROR] :: load_content :: Failed to load game.
の箇所だと思われる。 content-loadがうまく起動できずに強制終了しているようにも見える。 今現在解決方法がわからないので、もうしばらく頑張ってみることにする。

解決

どうやら、最初にアップロードしたnesファイルが死んでいたらしく、新たにDLしなおして、ちゃんとしたファイルをアップロードしたら、問題なく動きました。 みなさん、ファイル容量や転送方法、その後の確認など、基本的なことがおろそかになりがちなので、気をつけましょう。 良い教訓でした・・・

このブログを検索

ごあいさつ

このWebサイトは、独自思考で我が道を行くユゲタの少し尖った思考のTechブログです。 毎日興味がどんどん切り替わるので、テーマはマルチになっています。 もしかしたらアイデアに困っている人の助けになるかもしれません。